Subject: Re: Private IP address ranges? -reply IP Addressing IP address descriptions are found in RFC 1166, Internet Numbers. The Internet Network Information Center (InterNIC) maintains and distributes the RFC documents. The InterNIC also assigns IP addresses and network numbers to Internet Service Providers (ISPs), who in turn provide to their customers a range of addresses appropriate to the number of host devices on their network. The section that follows describe the various types of IP addresses, how addresses are given, and routing issues related to IP. IP addresses are written in dotted decimal notation consisting of four numbers separated by dots (periods). Each number, written in decimal, represents an 8-bit octet (sometimes informally referred to as a byte) giving each number a range of 0 through 255, inclusive. When strung together, the four octets for the 32-bit IP address. IP Address Notation 32-Bit Value Dotted Decimal Notation 01100100.01100100.01100100.00001010 100.100.100.10 11000011.00100000.00000100.11001000 195.32.4.200 The largest possible value of a field in dotted decimal notation is 255, which represents an octet where all the bits are 1s. IP Address Classes IP addresses are generally divided into different classes of addresses based on the number of hosts and subnetworks required supporting the hosts. As described in RFC 1166, IP addresses are 32-bit quantities divided into five classes. Each class has a different number of bits allocated to the network and host portions of the address. For example, 192.168.45.x describe a Class 'C' network with addresses ranging from 192.168.45.0 through 192.168.168.255. Class 'A' Addresses The class 'A' IP address format allocates the highest 8 bits to the network field and sets the highest-priority bit to 0(zero). The remaining 24 bits form the host field. Only 126 class 'A' networks can exist (0 is reserved and 127 is used for loopback networks), but each class 'A' network can have almost 17 million hosts. No new class 'A' network can be assigned at this time. Class 'B' Addresses The class 'B' IP address format allocates the highest 16 bits to the network field and sets the two highest-order bits to 1 and 0, providing a range from 128 through 191, inclusive. The remaining 16 bits providing a range from 128 to 191, inclusive. The remaining 16 bits form the host field. More than 16,000 class 'B' networks can exist, and each class 'B' network can have up to 65,534 hosts. Class 'C' Addresses The class 'C' IP address format allocates the highest 24 bits to the network field and sets the three highest-order bits to 1,1, and 0, providing a range from 192 through 223, inclusive. The remaining 8 bits form the host field. More than two million class 'C' networks can exist, and each class 'C' network can have up to 254 hosts. Class 'D' Addresses The class 'D' IP address format was designed for multicast groups, as discussed in RFC 988. In class 'D' addresses, the 4 highest-order bits are set 1, 1, 1, and 0, providing a range from 224 through 239, inclusive. Class 'D' addresses is currently used primarily for the multicast backbone (MBONE) of the Internet. Many routers and firewalls do not support MBONE or multicast and therefore ignore class 'D' addresses. Class 'E' Addresses The Class 'E' IP address is reserved for future use. In Class 'E' addresses, the 4 highest-order bits are set to 1, 1, 1, and 1. Routers and Firewalls currently ignore class 'E' IP addresses. Reserved IP Addresses Some IP addresses are reserved for special uses and cannot be used for host addresses. The following table lists ranges of IP addresses and shows which addresses are reserved, which are available to be assigned and which are for broadcast. Class IP Address Status A 0.0.0.0 Reserved A 1.0.0.0 through 126.0.0.0 Available A 127.0.0.0 Loopback networks on the local host B 128.0.0.0 Reserved B 128.1.0.0 through 191.254.255.255 Available B 191.255.0.0 Reserved C 192.0.0.0 Reserved C 192.0.1.0 through 223.255.254.255 Available C 223.255.255.0 Reserved D 224.0.0.0 through 239.255.255.255 Multicast group addresses E 240.0.0.0 through 255.255.255.254 Reserved 255.255.255.255 Local broadcast Private IP Networks RFC 1918 reserved three IP network addresses for private networks. The addresses 10.0.0.0/8, 192.168.0.0/16 and 172.16.0.0/20 can be used for anyone for setting up their own internal IP networks. Mark Teicher mark.teicher@predictive.com